1

Recently I installed SQL Server 2016 on my PC.

Here is the detailed information of my server :

Microsoft SQL Server 2016 (RC1) - 13.0.1200.242 (X64)
Mar 10 2016 16:49:45
Copyright (c) Microsoft Corporation
Enterprise Evaluation Edition (64-bit) on Windows 10 Pro 6.3 (Build 10586: )

After installing server on my PC then tried to install the below plugin's

  1. SQL Pretty Printer Add-In for SSMS V3.6.1
  2. SQLSentry Plan explorer

Problems:

  1. SQL Pretty Printer does not even install it was throwing error like

    enter image description here

    But the SQL Pretty Printer site says it works on SQL Server 2016 you can check the link.

    enter image description here

  2. Next SQLSentry Plan explorer was installed successfully but the plugin was not showing up in SSMS.

Version: v2.8 (Build 9.0.9252.0)

enter image description here

Can anyone help me out with this thing. Note both worked perfectly in SQL Server 2014.

closed as off-topic by Tom V, wBob, mustaccio, RolandoMySQLDBA, Erik Apr 4 '16 at 1:28

If this question can be reworded to fit the rules in the help center, please edit the question.

  • 7
    I'm voting to close this question as off-topic because these bugs should be reported to the vendor and this version of SQL Server 2016 is still beta software – Tom V Apr 3 '16 at 7:00
  • SQL Server 2016 RC2 is out already : ) – wBob Apr 3 '16 at 10:35
  • Annnnd, it's RTM as of June 1. – RedFilter Jun 5 '16 at 13:21
5

Vendors will need to catch up, as the add-in model and API have changed. This will lead to better extensibility, but for now you'll need to wait for the vendors to do this work. There is usually not much advantage to doing all of that work while the product is still in beta and the add-in model is still changing (the version of SSMS released on Friday is on a completely different VS shell and is radically different, which vendors knew would happen, and that would have rendered any work done against earlier RCs and CTPs a waste).

Please wait for RTM before expecting all vendors to have perfect integration. If you need these add-ins in the meantime, keep a supported version of SSMS installed too.

Or, in the case of Plan Explorer, use a simple workaround - all our add-in really does is provide a shortcut to right-clicking a plan, saving as .sqlplan, and then double-clicking in file explorer or using file/open in Plan Explorer. Or better yet, generate actual plans inside Plan Explorer, where you get much more useful metrics anyway.

Not the answer you're looking for? Browse other questions tagged or ask your own question.