1

I have Debian 8 (Jessie) server and i followed this procedure to upgrade from mysql 5.5 to mysql 5.7 https://dev.mysql.com/doc/refman/5.7/en/linux-installation-debian.html

Now, any script in the server that have an INSERT query is not working... The script is being executed but the INSERT query is returning always false with no error description...

Any ideas how to solve?

This is what i have installed enter image description here

Also, when i click on Database button in phpmyadmin

enter image description here

i'm getting this error

enter image description here

migrated from unix.stackexchange.com Apr 12 '16 at 19:41

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems.

  • Please provide SHOW CREATE TABLE, SHOW TABLE STATUS and the INSERT query. Also look in the file mysqld.err . – Rick James Apr 12 '16 at 23:03
0

If your question is about #1055...

1055: sql_mode includes ONLY_FULL_GROUP_BY. When doing a GROUP BY, you should include all the columns in the SELECT other than aggregates.

If your question is about INSERT, I don't see any supporting info.

-2

I had the same problem when i first upgraded to 5.7, i think strict sql mode is enabled by default and if you have tables with not null columns and no default value will behave like this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.