1

when I try to Install the Database I get this error message:

Source location is incomplete. Make sure you have downloaded and extracted all the relevant archives.

I did try this twice with the same error message with the main installation packages on Oracle website and from the support page (latest Patchset)

The files I tried are:

unzip linuxamd64_12102_database_1of2.zip
unzip linuxamd64_12102_database_2of2.zip

and for the patchset:

unzip p21419221_121020_Linux-x86-64_1of10.zip
unzip p21419221_121020_Linux-x86-64_2of10.zip

and when I create the ISO on my Mac

hdiutil makehybrid -o OracleDatabase12cEE.iso database/ -iso -joliet

all seems to be OK

I mount the ISO as a virtual CD/DVD in VMware then mount it in linux

tried to run the installation from the drive and after copying everything locally! and it's the same error message!

BTW I did run:

# yum install oracle-rdbms-server-12cR1-preinstall -y

# yum update -y

before trying to install!

also I login with ssh from my Mac

also I checked that everyone is the same as this article!

am I missing something?

  • 2
    To be honest, you created this problem yourself, by creating an unnecessary ISO file. All you need to do is copy both zip files into the VM, then unzip them into the same directory. For example, if you copied the zip fies to /home/oracle/install, then cd /home/oracle/install; unzip "*" -d .. Second, you do not need to install 12.1.0.2 on top of 12.1.0.1, patchsets are full installs since 11.2, you can start with 12.1.0.2 right away. Another alternative would be using a VMware shared folder. – Balazs Papp Apr 16 '16 at 16:56
4

The following is the excerpt of runInstaller.sh file

# Abort the install, if install/.oui file is not found in the stage area
#
if [ ! -f $CMDDIR/install/.oui ]
then
  echo "Source location is incomplete. Make sure you have downloaded and extracted
all the relevant archives."
        exit 1
fi

#

Which clearly states that if you are missing the .oui file it returns the given message.

Generally, after extracting the downloaded zip files manually we get two directories like database and database(0). The .oui file is hidden so we don't see it using general ls command and File Explorer. You can see it using ls -a command in Linux.

Solution:

Goto the second directory database(0)/install/ and copy the .oui file to the database/install directory.

[oracle@testsrv Desktop]$ cp 'database(0)'/install/.oui database/install
| improve this answer | |
0

without discarding anything of Mr. @JSapkota, i would like to say that You can also do with the help of GUI mode.

linuxamd64_12102_database_1of2.zip

linuxamd64_12102_database_1of2.zip

Procedure and Solutions to unzip the zip files & run the runInstaller.sh file

  1. Login with 'oracle user' and create a new folder for Oracle database
  2. Unzip the linuxamd64_12102_database_1of2.zip . you shall get folder name as database.
  3. Rename the Folder name as database1
  4. And again Extract the linuxamd64_12102_database_1of2.zip You shall get again database folder. Rename it as database2
  5. Again Go to the database2 folder. there you shall find two folder stage & install.

        within stage folder there will be component folder . In component
        folder there will be some 3-4 sub component folder (These folder's
        may be subtle vary from version to version of oracle database.
    
  6. copy all folders from component folder in database2

  7. Paste all these folders to in database1 component folder.

    Go to database1->stage->Components( paste all copying folder of sub
    components folder from database2 to here)
    
    
    After copying all components files to database1 , if you run the
    runInstaller.sh . You shall get error like "missing files,installing
    Oracle 12c on linux". Due to the '.oui' file.
    
  8. Again go to database2 folder. From oracle user terminal and checked the '.oui' file like that

$ ls -l

...oui ( you shall find out file like that)

From GUI interface do as 'Ctrl+h' in install folder.   because
'.Oui' file is a hidden file. copy this file and paste in
database1->install folder.

9.To run the ./runInstaller.sh file from database1.

How to run the runInstaller.sh

You must login from oracle user and go to the database1 folder where runInstaller.sh file is exist.

$ ./runInstaller.sh

Then you Oracle 12c database installation window screen will be pop up.

| improve this answer | |
0

Another solution:

The .oui file is available in the part2of2/install directory. Just copy that file and paste it in part1of2/install and run the ./runInstaller.

It worked for me.

| improve this answer | |
  • Exact answer has been given by others on this post. – JSapkota Feb 16 '18 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.