0

When I tried to start the service manually from a command prompt, I get a dialog stating:

Your SQL Server installation is either corrupt or has been tampered with (Unable to load SQLBOOT.DLL (HRESULT 0x8007007e)).  Please uninstall and then re-run setup to correct the problem.

I ran the Repair utility from the Maintenance section of the Setup and that resolved the problem. However, the next time the server was rebooted I had to go through the same process again. And then the next time the server was rebooted, I had to do it yet again.

The ERRORLOG is unhelpful, only showing messages from the shutdown, not the failed start attempt:

2016-04-20 19:35:45.70 Server      SQL Server is terminating because of a system shutdown. This is an informational message only. No user action is required.
2016-04-20 19:35:46.04 spid25s     Service Broker manager has shut down.
2016-04-20 19:35:46.04 spid25s     Error: 17054, Severity: 16, State: 1.
2016-04-20 19:35:46.04 spid25s     The current event was not reported to the Windows Events log. Operating system error = (null). You may need to clear the Windows Events log if it is full.
2016-04-20 19:35:46.05 spid5s      .NET Framework runtime has been stopped.
2016-04-20 19:35:46.21 spid5s      SQL Server shutdown has been initiated
2016-04-20 19:35:46.21 spid5s      SQL Trace was stopped due to server shutdown. Trace ID = '1'. This is an informational message only; no user action is required.

What would cause this corruption every time the server restarts?

9
  • Does the machine have multiple instances of sql server running ? Can you try from the bin folder sqlservr.exe –sInstanceName ? Also, make sure you are opening command prompt as "Admin". – Kin Shah Apr 21 '16 at 14:21
  • It has a default instance and a named instance, both of which have the same issue. I am running the command prompt as Admin. – Mark Freeman Apr 21 '16 at 16:00
  • 1
    Is there any antivirus software, antimalware, or disk defrag software installed? All of those have been known to cause issues. Additionally, some filesystem filter drivers (cough, antivirus, cough) may be causing the issue. – Sean Gallardy - Retired User Apr 21 '16 at 17:41
  • @SeanGallardy: There are no such drivers or software running on this server that is not running on all of our servers, but this is the only one with this issue. However, I don't believe that there is any such software on this server. I see nothing obvious in the Services list (such as Auslogic, Kaspersky, etc.). – Mark Freeman Apr 22 '16 at 14:00
  • Does this server happen to be a VM? Are there snapshots being taken of it? – Sean Gallardy - Retired User Apr 22 '16 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.