2

I am trying to install Oracle database 12c on Oracle Linux 7 version. But it is keep on failing with the below error.

[INS-30131] Initial setup required for the execution of installer validations failed.

CAUSE: Failed to access the temporary location.

ACTION: Ensure that the current user has required permissions to access the temporary location.

ADDITIONAL INFORMATION:

  • Framework setup check failed on all the nodes
  • Cause: Cause Of Problem Not Available
  • Action: User Action Not Available

Summary of the failed nodes ravilinux

  • Version of exectask could not be retrieved from node "XXXXXX"
  • Cause: Cause Of Problem Not Available
  • Action: User Action Not Available****

I see solutions are available for this error in Windows. But I don't see a solution for linux.

Can someone help on this please? I am trying to resolve this error for a week now.

I have /tmp with 3.9gb allocated. It is Free with 3.6GB still.

  • 3
    May be you want to check preinstallation requirements – mustaccio Apr 24 '16 at 21:22
  • 3
    Unlike Windows, rebooting is not a universal fix for linux issues. I googled "failed to access the temporary location" and it appears that this is an INS30131 error. (you should always include the exact error code). It appears that your /tmp space is too small. Have you religiously checked every prepreq in the Installation Guide? See docs.oracle.com/database/121/LADBI/pre_install.htm#LADBI7505 – EdStevens Apr 24 '16 at 23:06
  • Personally,I'd reinstall Linux, making sure that /tmp is big enough - 150% min. If you are experimenting, use 11XE. – Vérace Apr 26 '16 at 14:57
4

I tried creating /tmp which was not existing as a separate file system and kept 4gb of space. But the issue did not get resolved.

I try to keep my temporary file in a different place where the space available around 20gb. Still issue did not get resolved.

Finally I had to run the below command which resolved the issue. I couldn't find the solution so easily in google in first few pages as none of the people had raised this issue for Linux OS. Everyone was asking about Windows OS issue.

I had run the below command to provide execute permission for the folder CVU_12.1.0.2.0_**** under my temp directory.

chmod -R 777 /tmp/CVU_12.1.0.1.0_oracle/*

This resolved my issue. Thanks for the website which provided this solution.

I am posting here just to let others know, so that if anyone facing the same issue in future like me, can see this and get benefit.

Thanks for everyone who tried to answer my question. I really appreciate it.

  • You might want to consider marking your answer as the solution. – hot2use Nov 24 '17 at 7:36
1

INS-30131: Initial setup required for execution of installer validation failed

Cause: "Failed to access the temporary location".

This error occurs when you lack of space on /tmp directory. You should allocate space on /tmp according to the Installation Guide

Also review this Oracle Support Document Doc ID 2092409.1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.