0

I am trying to run a report but its giving this message:

An error has occurred during report processing. (rsProcessingAborted)
Query execution failed for dataset 'ParamYear'. (rsErrorExecutingCommand)
For more information about this error navigate to the report server on the local server machine, or enable remote errors 

I checked in Visual studio and I get this error:

    OLEDB provider for linked server sql10 reported change of schema version between 
compile time("182424452472301") and run time ("182454520418731") 
for table dbo.stud


Query:
SELECT DISTINCT Funding_Type
FROM            Destinations_1415_1516_Union
WHERE        (Year IN (@Year)) AND (AgeBand IN (@AgeBand)) AND (Completion_Status IN (2, 3))

Kindly let me know how to resolve this

1

What build of 2008 r2? Have you looked at this connect? https://connect.microsoft.com/SQLServer/feedback/details/672153/the-ole-db-provider-sqlncli10-for-linked-server-x-reported-a-change-in-schema-version-between-compile-time-and-run-time

Have you tried the workaround listed?

Workaround (From above connect):

I solved my problem with DBCC FREEPROCCACHE (ref http://msdn.microsoft.com/pt-br/library/ms174283.aspx)

Execute the first scenario where you delete the cache for the query that is causing the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.