1

I created a database (IaaS) from Azure marketplace (Windows server 2012 + SQL Server Web 2014). I Selected automatic backups to blob storage. Now I'm trying to do a test restore operation.

I imported my storage account to Management Studio (on VM). By right-clicking on bak file in blob and than going for Import Data-tier Application i started a wizard:

enter image description here

Having followed the wizard, I chose the proper destinations for DATA and LOGS (the same directory where other databases are).

The wizard finished with an error:

enter image description here

Error said:

The range specified is invalid for the current size of the resource. (Microsoft.SqlServer.StorageClient) The remote server returned an error: (416) The range specified is invalid for the current size of the resource.. (System)

I also tried a different approach:

I created an empty test database and tried to execute a Resore task on it. I chose Device and than URL for source. It allowed me to automatically connect to my Azure Storage account and select a bak file from blob.

As soon as I selected the bak file I got an error message:

enter image description here

Please note that all of the bak files have 0 Bytes size (first screen). This may have to do something with the failure.

All of the tasks I was performing form Management Studio installed automatically on the VM. Blob storage and SQL Server all came in a package form Azure marketplace.

I'm using SQL Server 2014 Web edition.

What am I doing wrong? How can I restore the database?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.