1
  • MySQL server version: 5.6.26
  • Linux: Linux 2.6.32-431.11.7.el6.ucloud.x86_64 #1 SMP Wed Jan 7 23:42:27 CST 2015 x86_64 x86_64 x86_64 GNU/Linux
  • Situation:
    • Aborted_connects increase 5-10 every minutes
    • log_warnings=2, but no error/warnings in error files
    • using TCPDUMP 3306 port, but cannot find any aborted connection request.

server status like below:

# Variable_name, Value
Aborted_connects, 7991
Connection_errors_accept, 0
Connection_errors_internal, 0
Connection_errors_max_connections, 0
Connection_errors_peer_address, 3
Connection_errors_select, 0
Connection_errors_tcpwrap, 0
Connections, 8051
Max_used_connections, 24
Performance_schema_session_connect_attrs_lost, 0
Ssl_client_connects, 0
Ssl_connect_renegotiates, 0
Ssl_finished_connects, 0
Threads_connected, 22

some referred server variables like below:

connect_timeout 10
max_allowed_packet  4194304
max_connect_errors  100
table_open_cache    2000
Connection_errors_accept    0
Connection_errors_internal  0
Connection_errors_max_connections   0
Connection_errors_peer_address  3
Connection_errors_select    0
Connection_errors_tcpwrap   0

at least the reason was a ZABBIX setting for mysql template wrong. Does somebody know why the ZABBIX_AGENT of current server connect error were not be writed in the error log of mysql when log_warning level is 2?

2
  • percona.com/blog/2008/08/23/… shows a case when this counter is incremented on connection attempts with bad credentials.
    – jkavalik
    Commented May 9, 2016 at 6:37
  • @jkavalik had try, but nothing in output.
    – Grant Wu
    Commented May 9, 2016 at 7:53

2 Answers 2

1

Aborted_connects/Connections is nearly 1. This is extremely high.

Threads_connected is always 1 or more because "1" is the connection that is doing the SHOW STATUS. Max_used_connections = 2 probably does mean that two connections were connected at some time. It is a high-water-mark.

0

Found a Zabbix_Agent process connect to mysql server. I cannot understand, why the log_warnings=2 cannot log the warnings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.