0

I have a local installation of Oracle Before i can connect directly via SqlPlus but now when i try to connect i have this error :

ERROR: ORA-01034: ORACLE not available ORA-27101: shared memory realm does not exist Linux-x86_64 Error: 2: No such file or directory Additional information: 3640 Additional information: 684464879 Process ID: 0 Session ID: 0 Serial number: 0

Can you tell me what is the cause of this Error ? how can i solve it ?

  • How did you start your database that you try to access? Normally you get this error if the database is not open. – Marco May 10 '16 at 12:11
  • I tried to start the database and they said it s already started – gani amine May 10 '16 at 14:12
0

Solved by changing the value of

"kernel.shmall" in the file /etc/sysctl.conf

| improve this answer | |
0

Make sure the database is actually running, and if not, start it. If you have an init script, then it's typically something like:

sudo service oracle start

This has been asked before for Oracle 11g - the answers and comments to that question may be helpful here: ORA-01034: ORACLE not available in oracle 11g

| improve this answer | |
  • The database is actually running and it s not ORACLE XE i already saw this questions but didn't work for me – gani amine May 10 '16 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.