8

I have installed mysql 5.7, and from time to time (once per several days) it looks for updates (as I understand). Console window opens for several seconds, and then dissappear. It doesn't care, that I'm watching a movie in this time, and this console is on the top of my player. It's really annoying, why MySql is updating in this user unfriendly way? Can I configure it to do it silently?

7

I may be running a more recent version of MySQL, but what I had to do to disable this was:

  • Run the MySQL Installer (located at C:\Program Files (x86)\MySQL\MySQL Installer for Windows)
  • Click the wrench icon
  • Un-check the box to check for updates
2

In the System Tray - click on the Dolhin icon:

Dolphin icon

Actions -> Options -> Untick "Automatically check for updates every x weeks".

I'm giving this a +1 because I also found it annoying and your question prompted me to investigate.

  • In what application should I use these instructions? – Chrips Aug 27 '17 at 15:01
1

Make sure MySQL Notifier is running. Taskbar -> System Tray -> MySQL Notifier, Select Actions -> Options Uncheck the "Automatically check for updates every x weeks".

This may limit the security or functionality of your installation.

enter image description here

0

Best is to hide the console only, and let it do what it's meant to do in the background.

Go to 'Task scheduler' > expand 'Task scheduler library' > 'MySQL' > 'Installer' > 'Manifest Update' > right-click 'Properties' > choose 'Run whether user is logged on or not' > check 'Do not store password...'

That should do it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.