3

We have MySQL Front installed in our server, I can connect to it with no problems, there is a db with tables, everything fine.

Now I installed MySQL workbench (client) in the same server, but can't connect, I receive a "Malformed packet" error when I test connection. The port is 3306, hostname is localhost (as I'm logged in the server), user and password are the same.

Why shouldn't I be able to connect to the same server with workbench? Actually I need to connect to it using Entity Framework, but I can't due to this error.

I don't know what info would be useful (feel free to ask anything), I can only guarantee the windows service is running, the firewall is not blocking (I even tried disabling it).

If I try to connect with workbench using an "invalid" username (e.g "foobar"), the connection is sucessful (which is strange imo), but then I can only see the "test" database, and I can't see the actual database I want to (as in MySQL Front).

  • Try uninstalling this "MySQL Front" package? – Vérace May 18 '16 at 16:29
  • 1
    Try increasing max_allowed_packet? – Luciano Andress Martini May 18 '16 at 17:02
2

After reseting root password, I could connect with workbench. I still can't connect with old users (which were already created), but connecting with root and creating new users with workbench allows me to connect with these new users.

It looks it has something to do with the password, or the way MySQL Server stores password for users. I don't know the actual reason for the error, but this solved my problem.

Thanks for the suggestions!

0

A malformed package is usually a sign that you didn't connect to the expected service (in this case the MySQL server). Doublecheck that the expected server is running behind the given port on the given machine.

0

Malformed packet if generated by an authentication breach (Workbench newer versions)... The password is not long/strong enough.

Solution: Update the user's password to a stronger/longer one and you will be able to connect.

-1

This problem still exists. It may be caused by password related issues, but this problem is only MySqlWorkbench related, while a bunch of third party tools like Heidi, Database Browser, DBDesigner etc, works as a charm with no problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.