3

I have 6 months of backups left to perform and a single day can take up 200MB in raw mysqldump --extended-insert=false --complete-insert form. If I try to dump more than a day worth of data I get mysqldump: Error 2013: Lost connection to MySQL server during query when dumping tabletableat row: 657925 (the row number changes).

my mysqldump query is mysqldump -h dbName.db.id.hostedresource.com -u 'user_name' -P 3306 -p'password' --net_buffer_length=4096 --single-transaction --extended-insert=false --complete-insert=TRUE --no-create-info --compact --insert-ignore --quick --where="start>='2016-01-13 00:00:00' AND start<'2016-01-15 00:00:00'" dbName table names

same issue exists with --extended-insert=true or --extended-insert=false and since it's a cloud server I have no access to the server or it's admin account to change buffer or cache settings. Is there any hope of escaping this mindless drudgery within the next week!

0

In my case it helped to stop Apache, do mysqldump and then start Apache.

Nothing else helped, no options that were recommended. Nothing (and I searched all posts). I have low 512M memory and maybe this is also the cause.

0

Your problem has to do with the silent killer of all mysqldumps : PACKETS

You need to set --max-allowed-packet=1073741824 to accommodate bigger and better buffering of MySQL Packets. Please see all my past posts on dumps and packets.

What could also contribute to this is how your ethernet is configured. I recently ran across an issue with MySQL Replication cross-region. The slave IO thread connectted to the Master but the Master could not acknowledge to the slave that it opened on the Master, so the IO thread terminated on the Master. Turns out the servers were using jumbo frames. I referred to this link to the Amazon Documentation, lowered the MTU on the server's eth0, and now connections can survive cross-region connections.

Main point is this: Packets that are too small will drop a mysqldump liek a bad habit, even if the mysqldump is within the local machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.