1

I am trying to set the innodb_log_file_size option in a MySQL 14.14 (distrib. 5.6.30) installation on Ubuntu 15.10 to solve an issue (importing a database with large BLOB fields) however the log size keeps defaulting back to 48MB. I have read a number of posts about this but have not yet found a solution. Any help is appreciated.

My process:

  • SET GLOBAL innodb_fast_shutdown = 0; (in a MySQL session)
  • /etc/init.d/mysql stop
  • rm /var/lib/mysql/ib_logfile0 and ib_logfile1
  • (edit my.cnf)
  • /etc/init.d/mysql start

In /etc/mysql/my.cnf (which is a symlink to /etc/alternatives/my.cnf which is a symlink to /etc/mysql/my.cnf.migrated):

[mysqld]
...
innodb_buffer_pool_size = 1000M
innodb_force_recovery = 0
innodb_file_per_table = 1
innodb_file_format = barracuda
innodb_read_io_threads = 16
innodb_log_file_size   = 1G
innodb_log_files_in_group = 4

I also set this variable in /etc/mysql/mysql.conf.d/mysqld.cnf in case that was taking priority.

The log file reads:

2016-05-19 09:25:23 24141 [Note] Plugin 'FEDERATED' is disabled.
2016-05-19 09:25:23 24141 [ERROR] Function 'innodb' already exists
2016-05-19 09:25:23 24141 [Warning] Couldn't load plugin named 'innodb' with soname 'ha_innodb.so'.
2016-05-19 09:25:23 24141 [ERROR] Function 'federated' already exists
...
2016-05-19 09:25:23 24141 [Note] InnoDB: Using atomics to ref count buffer pool pages
2016-05-19 09:25:23 24141 [Note] InnoDB: The InnoDB memory heap is disabled
2016-05-19 09:25:23 24141 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2016-05-19 09:25:23 24141 [Note] InnoDB: Memory barrier is not used
2016-05-19 09:25:23 24141 [Note] InnoDB: Compressed tables use zlib 1.2.8
2016-05-19 09:25:23 24141 [Note] InnoDB: Using Linux native AIO
2016-05-19 09:25:23 24141 [Note] InnoDB: Using CPU crc32 instructions
2016-05-19 09:25:23 24141 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2016-05-19 09:25:23 24141 [Note] InnoDB: Completed initialization of buffer pool
2016-05-19 09:25:23 24141 [Note] InnoDB: Setting log file ./ib_logfile101 size to 48 MB
2016-05-19 09:25:23 24141 [Note] InnoDB: Setting log file ./ib_logfile1 size to 48 MB
2016-05-19 09:25:23 24141 [Note] InnoDB: Renaming log file ./ib_logfile101 to ./ib_logfile0
2016-05-19 09:25:23 24141 [Warning] InnoDB: New log files created, LSN=2798779859498
2016-05-19 09:25:23 24141 [Note] InnoDB: Highest supported file format is Barracuda.
1

We tried the same procedure on an Ubuntu workstation with MySQL 5.7.x on Ubuntu 16.04 and it worked without issue.

Based on this, we decided to upgrade our server's OS to Ubuntu 16.04 which upgraded MySQL to v5.7.12. After changing my.cnf to reflect changes in some option names and restarting the service, the log files now have the correct sizes and the problem is resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.