I have a stand-alone MongoDB instance running in windows. It's recently experiencing slowness and my troubleshooting has found the following symptoms.

  1. The slowness normally occurs after a full text search query against a huge collection. I guess this is because it swaps many pages in the collection from disk into memory hence data from other collections are squeezed out of memory.
  2. The server memory usage is capped around 55%. The server (Win2012) has 32GB of memory but MongoDB is not trying to utilize beyond 16GB.

I have seen a couple of Q&A in limiting MongoDB memory usage but not on how to encourage MongoDB to be more greedy.

Would anyone has experience with similar issue?

  • MongoDB: 3.2.0
  • Storage Engine: wiredTiger
  • OS: Win2012
  • Memory: 32GB


2 Answers 2


Figured out why, here is the explanation.

wiredTiger has a default cache size limit of 60%RAM - 1GB, should be overwritten in a system with large memory.


Please check your Index Size must fit to the RAM, and also With WiredTiger, MongoDB utilizes both the WiredTiger cache and the filesystem cache.

For systems with up to 10 GB of RAM, the new default setting is less than or equal to the 3.0 default setting (For MongoDB 3.0, the WiredTiger cache uses either 1 GB or half of the installed physical RAM, whichever is larger).

For systems with more than 10 GB of RAM, the new default setting is greater than the 3.0 setting.

Via the filesystem cache, MongoDB automatically uses all free memory that is not used by the WiredTiger cache


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.