1

I'm setting up replication between the live server (running Windows 2008 R2 and MySQL 5.5.19) and a dedicated replication server (running CentOS 7 and MySQL 5.6.30). The CentOS box does have MySQL not MariaDB.

In the master my.ini, I've set:

server-id=131025185082

In the slave my.cnf, I've set:

server-id=192168001182

The server is generating a mysql-bin and I've configured the slave to connect. But; I'm getting a 1593 error:

Fatal error: The slave I/O thread stops because master and slave have  equal MySQL server ids; these ids must be different for replication to work (or the --replicate-same-server-id option must be used on slave but this does not always make sense; please check the manual before using it). The log position given is the start point from SHOW MASTER STATUS on the master.

When I do:

show variables like 'server_id';

on both machines, they both come back with:

+---------------+------------+
| Variable_name | Value      |
+---------------+------------+
| server_id     | 4294967295 |
+---------------+------------+

Can anyone suggest what's gone wrong here?

Thanks.

1

If both the servers showing same server-id, you can set this to some other value and check again.

On Master:

server-id = 1

On Slave:

server-id = 2

Make sure that, while giving change master settings, give the host name as ip address of the master server. This should work, check again and see if the same issue exists. I hope this will help you.

| improve this answer | |
  • I've changed the slave server-id & it worked. What was wrong with 192168001182? Thanks – JezB May 24 '16 at 8:55
  • 1
    The highest server id allowed is 4294967295 (dev.mysql.com/doc/refman/5.6/en/…), just a little under 4.3 billion. Your number is over 192 billion. Way too big !!! – RolandoMySQLDBA May 24 '16 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.