6

Before: mysql 5.6. One of the columns in the table is created as follows:

`f_stamp` datetime NOT NULL DEFAULT '0000-00-00 00:00:00'

When i view this field in mysql client or using DataGrip, this field is displayed correctly.

Now: mysql 5.7. The field is not displayed correctly (more precisely, it is causes en error). I delete from mysql config following flags: NO_ZERO_DATE, NP_ZERO_IN_DATE and STRICT_TRANS_TABLES. And now, looking at this field i see:

  1. Using mysql-client: 0000-00-00 00:00:00
  2. DataGrip: null

How to change server's option for support this non-standard datetime value, initialize by '0000-00-00 00:00:00' ?

UPD: https://youtrack.jetbrains.com/issue/DBE-3377

1
  • There was probably a good reason for making this bogus date illegal. Consider changing the application.
    – Rick James
    Jun 6, 2016 at 5:02

1 Answer 1

6

It is the JDBC driver option we changed in DataGrip by default. But you can configure it the way you like:

enter image description here

1
  • 1
    Wow. This took me way to much time to figure out. Can't fathom why they would display a value differently than it technically is reported by the server. Especially in a tool used for technical analysis.
    – Maurice
    Apr 17, 2019 at 8:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.