1

I'm trying to change the max_allowed_packet setting on mysql cluster (version 7.4.8) - i have 5 nodes

  • 2x SQL Node
  • 2x Data Node
  • 1x Managament Node

I have updated the my.cnf on all of the servers ->

[mysqld]
datadir=/var/lib/mysql
#socket=/var/lib/mysql/mysql.sock
user=mysql
ndbcluster
ndb-connectstring=manager-db
default_storage_engine=ndbcluster
port=3306
max_allowed_packet=1073741824

But show variables like '%max_allowed_packet%' still returns 524288000

What am i doing wrong ? where do i need to set it ?

  • This logically needs to be done on SQL nodes where MySQL services are installed and you need to see what show global variables to verify the value and you can change the value on fly as well using set global max_allowed_packet..hope it helps – Nawaz Sohail Jun 13 '16 at 11:24
  • @NawazSohail yep your right - the reason i didnt see the change was as my answer below - needed to restart the client session ! – Manse Jun 13 '16 at 14:57
0

The answer is indeed the SQL Nodes - the key factor is related to the client - the setting doesn't apply until you close the client session and reopen it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.