3

I have set up SSRS on MS SQL 2014 Dev Edition using the ReportServer built in account as the Service Account.

My machine name is: POUYASAGER
My local login is pyous
I have given the ReportServer account full permissions to:

C:\Program Files\Microsoft SQL Server\MSRS12.MSSQLSERVER\Reporting Services

I have checked that SecureConnectionLevel is set to 0 in the rsreportserver.config file.

I set up ReportServer as the virtual directory so that the Report Server Web Service URLs would be: http://POUYASAGER:80/ReportServer

When I click on the link in the Reporting Services Configuration Manager which is the same as above, I get:

The permissions granted to user 'POUYASAGER\pyous' are insufficient for performing this operation. (rsAccessDenied)

When I navigate to: http://127.0.0.1:80/ReportServer, an authentication pop-up asks for a username and password.

When I navigate to the reports manager using: http://pouyasager:80/Reports, I get:
Error
Unable to connect to the remote server

How can I get SSRS working properly?

EDIT: I added "localhost" to the host headers and still got the same error.
EDIT: Using Chrome with Admin permissions, I navigate to http://localhost:80/ReportServer with the same results.

2

Adding the account you are logging in on your OS will allow for you to connect to SSRS. You are provided with a 403 error message directly related to an access denied. The type of access being denied here is at the database level, mainly for the Reportserver$ database. Your OS login is unable to personify NT SERVICE since it does not have a login on the server and guest account being probably disabled.

Additionally, verify the following: 'C:\WINDOWS\Microsoft.NET\Framework\V2.0.050727\Temporary ASP.NET Files'. (or where ever your .NET framework is installed on your machine)

Right click on the "Temporary ASP.NET Files" and select properties->secutity.

See if the "NETWORK SERVICE" is already part of the "User/Group" section. If not add it by typing "Network Service". If it's already there then grant the write permissions.

  • Yes. This is a big annoyance I have run into after a new SSRS install as well. Apparently, the only way to access the security settings after a new install is as a local admin. Don't just add the account locally, grant local administrator to it as well. Once you are a local admin, you should be able to launch into the app, add other users and then if you want, remove the local admin privileges. – Shooter McGavin Oct 28 '16 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.