0

This question already has an answer here:

We have successfully setup the Alwayson with different subnets and it was working fine. But unfortunately the existing NAS storage had a problem. Now our storage team provide new storage IP.

We need to replace the existing storage configuration with new one in Shared network location wizard . Is there any way without removing the existing setup due we already configured around 500 database.

Please find the below screen shot and do the needful.enter image description here

marked as duplicate by Marcello Miorelli, RDFozz, John Eisbrener, Mr.Brownstone, hot2use Oct 31 '17 at 11:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Can you please add more detail on what exactly the problem is? Have your existing databases / files been moved and still working? Is the only problem the default folder in the screenshot; because that's likely just the default backup location. – Cody Konior Jun 16 '16 at 3:34
1

The shared network location in that wizard is only used in the wizard and only used as a temporary location to backup the databases to and restore from that location to any of the replicas that could host that database.

Apart from that, it has no use and is not used internally anywhere in availability groups.

You can easily change the value to whatever new value your storage team has given you, but you'll want to double check that all of the replicas have access to said shared location.

  • Thanks for the quick response. you means after setup the alwayson if we remove the shared drive at that time also existing replicas working fine without issues. – Baazi Jun 16 '16 at 11:11
  • Assuming you have nothing else that requires or is dependent upon it, yes. – Sean Gallardy Jun 16 '16 at 16:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.