-1

dblogin userid ogg_user, password AADAAAAAAAAAAAIAKAQIJAGAMFUFKFBGQHXBJIWGECTEIAZHJFYALFFIBGHGJBPFBCPBKEPCRCRHAESJ, AES128, encryptkey securekey1 ERROR: Unable to connect to database using user ogg_user. Please check privileges. ORA-01017: invalid username/password; logon denied.

What are the privileges required to get the connection done. I have given all required for a Goldengate User including DBA, but still there is an error.

Let me know.

Thanks!

  • It's not a matter of privileges. It's a matter of supplying a valid username and password. The error message is clearly "ORA-01017: invalid username/password", and Oracle is not clever enough to lie about that. Beware that beginning with 11g, passwords became case sensitive. – EdStevens Jun 16 '16 at 20:30
  • I understand the fact, however this problem is something related to GoldenGate configuration where we use Encryption Key to login to the database and that is what I tried to achieve here. The below link can help you understand my motto: - gavinsoorma.com/2010/07/… – Gaurav Bhaskar Jun 17 '16 at 6:15
0

What OGG version are you using?

Instead of DBA role, have you tried granting the required privileges through dbms_goldengate_auth.grant_admin_privilege?

"Requirements When Configuring Extract or Replicat in Integrated Mode (Oracle)

If using DBLOGIN to issue ADD EXTRACT, ALTER EXTRACT, or REGISTER EXTRACT to initiate integrated capture or ADD REPLICAT, ALTER REPLICAT, or REGISTER REPLICAT to initiate integrated Replicat against an Oracle database, the user who issues DBLOGIN must:

Have privileges granted through the Oracle dbms_goldengate_auth.grant_admin_privilege procedure."

Reference

  • Hi, I am using the 12.1.2.0.0 version of GG and Database Version is 11.2.0.4. I have given all required permission which is required for GG Configuration. DBA configuration was something I thought of giving at last when everything I tried was not working. This is something I am trying to configure - gavinsoorma.com/2010/07/…. I have seen other bloggers using the same way and they are able to login using Encrypted key, however I got the error. What do you suggest now? – Gaurav Bhaskar Jun 17 '16 at 6:21
  • How about sharing how you fixed it? – EdStevens Jun 18 '16 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.