I have 2 database on one server. I can connect to the database with normal users but cannot connect with sys and system users and invalid username/password occurs. before that I dropped one of the databases and during dropping that database, this error occurred:

DIM-00014: cannot open the windows NT service control manager.O/S-Error:(OS 5) Access is denied

I check if I can connect sqlplus /nolog and conn / as sysdba and it did not worked and below error occurred:

12560: tns protocol adapter error

anybody help!

  • What is the value of your ORACLE_SID when you try to connect? The one that you dropped?
    – Marco
    Jun 20, 2016 at 12:13
  • @Marco No, I have set ORACLE_SID, ORACLE_HOME, and TNS_ADMIN correctly and other users of that database can connect to the database but sys and system cannot.
    – E_Salamon
    Jun 20, 2016 at 12:20
  • How did you attempt to drop the database, the step by step? And have you run those commands in a prompt with administrator privileges? Jun 20, 2016 at 18:17
  • In spite of your assertions otherwise, if 'sqlplus / as sysdba' returns a protocol adapter error, it really means only one thing. ORACLE_SID is not set to indicate a database for which there is a running Windows service. If "other users" can connect, I'll bet they are using a tns connection, not the bequeath connection indicated by your failed attempt. Are they connecting with something like 'sqlplus user/pwd@mydb'?
    – EdStevens
    Jun 21, 2016 at 0:22
  • To @GuilhermeMesquitaX, Yes I think that is maybe one problem that causes the errors. unfortunately I ran the {DBCA} without administrator privileges. yesterday I used regedit and delete unnecessary files from HKEY_LOCAL_MACHINE ->SOFTWARE->ORACLE and HKEY_LOCAL_MACHINE ->SYSTEM->CurrentControlSet->'Related Oracle Files' and now the error for sys is the same but the error for system user is "the account is locked".
    – E_Salamon
    Jun 21, 2016 at 4:00

1 Answer 1


I finally found a solution. I changed sys password using orapwd. There is just one issue. As documentation says, the password for users which do not have sysdba or sysoper privileges will be expired after some time. So, to avoid this login as sysdba and grant sysdba and sysoper to the sys.

  • passwords for non-sysdba users are handled entirely differently from those of sysdba users. Non-sysdba users have their passwords stored in the data dictionary, along with other properties of their account. Passwords of sysdba users are stored in the external password file. Passwords for sysdba users never expire. Period. There should be no need to grant sysdba and sysoper to SYS, as SYS has those privileges by definition.
    – EdStevens
    Jul 1, 2016 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.