2

After trying many different suggestions as found on the net, I'm still unable to establish a connection from the Workbench application to the server. Here is a brief list of things I tried:

1) Granting all privileges on . to 'root'@'%' ; (+flush privileges),

2) Creating a new user 'test'@'%' and granting all privileges (yes, it is the same as above, but had to try with someone different from root),

3) Create a user as 'test2'@'' with all privileges,

4) Turning off firewall in both server and my computer,

5) Updated the file /etc/my.cfg my adding a bind-address = 0.0.0.0 line (there wasn't any such line, to begin with; note the location of this file which differs from what is presented in many posts; in my installation, there is no such a folder /etc/my.cfg/...),

...

The error I get is always that cannot establish a connection (with the 4 steps to check; obviously, I checked them all and it should work).

I have Workbench installed on Windows 10 and I'm using the standard MySQL included in the Oracle Linux 7 installation ISO.

Could anyone suggest additional checks to be made and to find what the issue is?

  • Were you able to connect from other client? (Other than workbench). Also, have a look at skip-networking value: dev.mysql.com/doc/refman/5.7/en/… – Jehad Keriaki Jun 27 '16 at 20:05
  • Thank you @JehadKeriaki for your reply. It turned out that there was nothing wrong with the MySQL parts, but rather with Linux: Firewall and Selinux were up and blocking all accesses from outside. Yes, I know, I should had checked that before posting my question, but you know how it goes... – FDavidov Jun 28 '16 at 5:14
2

The issue had nothing to do with MySQL parts. It turned out that Linux's firewall and Selinux were blocking access from outside the server. Once turned off, the connection worked perfectly.

Two things I learned from this:

1) Check better the ENVIRONMENT before blaming the product,

2) MySQL could improve the clarity of the messages and include environment elements that could be the source of the issue (I wasted 1/2 day chasing this stupid issue).

  • 1
    Please mark your own answer as correct as soon as you can - it might help others. Also, if you'd care to file a bug report/feature request, then post the URL and I'll post a "me-too". – Vérace Jun 29 '16 at 0:11
  • Of course!! It is just that this forum requires you to wait 1 day to accept your own answer (though I don't understand the motivation for such delay). – FDavidov Jun 29 '16 at 5:49
  • Probably because it's very easy to convince oneself that one is correct - I mean we can always spot the flaw in others, but never in ourselves - O wad some Power the giftie gie us, To see oursels as ithers see us! Burns. This 24 hours gives some time for reflection IMHO. – Vérace Jun 29 '16 at 6:04
  • Well... yes, but then, if I happen to solve my problem (say) 10 minutes after I posted it, I can write an answer BUT, since I cannot vote for it, other readers would need to go through the whole answer to understand that this is the actual solution. Anyway, that's the way the designers thought and, altogether, they made a terrific job so far!!! – FDavidov Jun 29 '16 at 6:09
  • @FDavidov well i guess several days have passed now, but before your mark your own answer as accepted you should explain how you solved the issue to help others.... – Xsmael May 10 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.