0

I have two node RAC servers hosting 4 databases running on 11.2.0.3 version in RHEL OS. The underlying LUNs assigned to the ASM is not currently multipathed, meaning the disk sequence would change when my server node reboots causing my ASM not to mount the diskgroups and therefore I have planned to create new disks using ASMLib with newly added LUNs which would be multipathed.

I got new LUNs and I created new disks using ASMlib as well in node 1. Once created in node 1 and scanned the same in node 2 for disks to be discovered in node 2. The disks are discovered in both the nodes.

After creating diskgroups when I try to mount them, in node 1 it is getting mounted, but in node 2 it fails giving

ORA-15063: ASM discovered an insufficient number of disks for diskgroup

Please note I have not given scan exclude and scan order in both the nodes inspite of this being multipathed disks, yet the same is getting mounted in node 1 but not in node 2.

What could be the issue?

0

As per MOSC, this error can happen if the content of /etc/sysconfig/oracleasm is different across the nodes.

The recommendations are:

1 - Make sure the file is the same on both nodes, and ORACLEASM_SCANORDER/ ORACLEASM_SCANEXCLUDE have the following content:

ORACLEASM_SCANORDER="dm"
ORACLEASM_SCANEXCLUDE="sd"

2 - Make sure the symbolic link is the same on both nodes after executing:

ls -l  /etc/sysconfig/oracleasm

3 - After checking/ making necessary changes, rescan the disks with:

oracleasm scandisks

For complete reference, please check the following note if you have access to MOSC.

ORA-15186 ORA-15063 on node 2 (Doc ID 1526920.1)

  • As I mentioned earlier, those parameters remain the same in both the nodes. I have not set anything for that. – tesla747 Jun 28 '16 at 1:55
  • @tesla747, were you able to fix the error? I haven't experienced the error, but I'm curious about what would be the solution. Thanks. – GuilhermeMesquitaX Jul 5 '16 at 17:26
  • I came across another MOSC article: How to Configure LUNs for ASM Disks using WWID, DM-Multipathing, and ASMLIB on RHEL 5/OL 5 and RHEL 6/OL 6 (Doc ID 1365511.1), but don't know if that's exactly your case. – GuilhermeMesquitaX Jul 5 '16 at 17:27
  • i'm going to go with disabling multipath in 2nd node and then proceed with migration.. once done with migration, I will enable multipath and start the databases. no other way. – tesla747 Jul 6 '16 at 5:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.