7

I'm having a strange problem with my SSMS 2016. Within the query window backspace, del, up, down, left, right keys have stopped working. When I reset my environment settings with "Import and Export Settings" to default setting it works but the changes don't persist when I exit the SSMS client. Every time I launch SSMS 2016 I have to do this exercise.

I also have SSMS 2014 on the same system, which works with out any problem, I tried to uninstall and install the SSMS 16 client but no luck.

Any one having the same problem?

Help please, how can I uninstall SQL Server Management Studio 2016 completely?

  • Also remember the settings are with Visual Studio since SSMS is now using the VS fully. So times where I install any VS 2015 update my settings in SSMS 2016 will get reset. I have not tried since the October release of SSMS though, so they may have fixed it. – Shawn Melton Oct 19 '16 at 17:19
  • What build of SSMS do you have installed? As well, when you are resetting what collection are you picking to reset (default option is to SQL Server 2008 R2)? – Shawn Melton Oct 19 '16 at 17:22
  • What language version of the OS are you running and what language version of SQL Server Management Studio 16 are you using? – jcolebrand Dec 22 '16 at 16:31
  • possible related: stackoverflow.com/questions/484248/… – jean Aug 24 '17 at 12:58
1

This is an old question, but I fell prey to this issue recently and found that SSMS wasn't overwriting a "bad" settings file. To fix it, I had to close SSMS and simply delete the settings file using Windows Explorer. SSMS then loaded with the default settings when I started it back up and I was able to reset things to the way I wanted once more without issue. I suspect something occurred on the network that prevented SSMS from overwriting the old file (as my path is mapped to a UNC copy of the My Documents folder).

The settings file location can be found within SSMS at ToolsOptionsEnvironmentImport and Export Settings

enter image description here

Hopefully this helps someone else in the future.

1

This happened in SSMS 2017. There was a pop-under "Add table to view" dialog that I didn't know about. When I went to close SSMS it warned me about the dialog (which I could not close/cancel), then gave me an ugly exception about protected memory.
After restarting SSMS it all worked again.

  • Welcome to DBA.SE! You may want to take the tour, to better understand how the site works. Not sure how good a match this is to the problem presented in the question, as that problem persists over multiple restarts. – RDFozz Aug 23 '18 at 16:30
-2

To uninstall SQL Server: you may try to do with cmd. perform the uninstall from the command prompt, C:\SSMS2016\SSMS-Setup-ENU.exe /ACTION=Uninstall

-3

You need to make sure to follow all of the pre-install instructions as there are critical items that need to be followed for all SQL Server 2016 features to work correctly. You can see the list here.

https://msdn.microsoft.com/en-us/library/dn876712.aspx#bkmk_ga_instalpatch

You may not need to uninstall 2016 to get this patch to work, but your mileage may vary.

  • Thanks. But the problem is not with SQL Server 2016 – user1716729 Jul 1 '16 at 18:50
  • 1
    Is SSMS a separate install than SQL Server 2016 now? – Anthony Genovese Jul 1 '16 at 20:20
  • 1
    yes. from 2016 onward – user1716729 Jul 1 '16 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.