3

I am aware this question has been asked before. I have been following the extensive troubleshooting steps at MSQL Tips as well as every answer I can find on Google. I am really stumped.

The error is as follows:

enter image description here

I cannot seem to get past this error. Every time I install/uninstall MS SQL Server I receive the same error. I have even performed a hard reset of the laptop removing even the BIOS information but I still get the same error. I have discovered that installs of MS SQL Server are concurrent so this perhaps explains it.

I even set up a virtual machine running Windows 7 to debug and got the exact same message. The application can be run on a different workstation and works perfectly. It seems the issue is something hard coded on to my computer.

  • Have you tried OSQL -L or SQLCMD -L to see if the server is responding? – Mister Magoo Jul 11 '16 at 23:17
5

Not knowing the full details of your issue by your question try the following:

Option 1:

Temporarily disable Windows Firewall and test your SQL script once more:

enter image description here

Option 2:

Make sure NetBIOS is enabled in the TCP/IP settings of the network adapter you are using:

enter image description here

Option 3:

Ensure that SQL Server protocols are enabled through SQL Server Configuration Manager:

enter image description here

Option 4:

Try a combination of two or more options above.

0

In my case (Windows 7, SQL Server 2014 Express, call sqlcmd from a bat file, named pipes error 53), it was a combination of:

  1. Enabling Named Pipes and TCP/IP in SQL Server Configuration Manager\SQL Network Configuraton, as suggested in @Sting's answer above
  2. Using the correct Server Name in

    sqlcmd -S <ServerName> -i <.sql file>
    

    You can get this string from the Connect to Database Engine pop-up in MSSQL Server Management Studio, or by querying the database:

    SELECT @@servername
    

The command line:

    sqlcmd -L

was no help in this case, as it still lists a blank line, even after I got the batch file working.

0

You may get this type of error due to using small (-s) instead of capital (-S)... please check the parameter character by changing upper/ lower case...

I had already faced this type of issue and resolved by doing this.

0

If using localdb, put (localdb)\ before server instance name. I should particularly stress on using a back-slash \.

(BTW, experiences are only useful when we remember them, unlike me re-experiencing and re-finding the solution after 2 years...)

New contributor
Small Boy is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.