0

I wonder if this question will need to be moved to the SharePoint SE site, but I believe this could be a simple a SQL Server security fix.

A little back story: Back in April we upgraded our SharePoint SQL Server backend (mirrored) from SQL 2005 to SQL 2014. We did this by way of mirroring from SQL 2005 (primary) to SQL 2014 (mirror). I don't believe the security settings and logins were extracted from the old server and placed in the new. I'll have to reach out to my infrastructure department to see if the server has been completely decommissioned.

My SharePoint Admin is trying to create a new site from the SharePoint Central Admin Site (SharePoint 2010), but gets the following error.

Error "Directory lookup for the file "D:\Data\NewSiteDB.mdf" failed with the operating system error 2(The system cannot find the file specified.). CREATE DATABASE failed. Some file names listed could not be created."

He told me that he used to be able to use his Active Directory account or a SQL Server SysAdmin account to create new sites, now he can't. I'm pretty sure that his AD account was not an admin of any kind on the SQL Servers regarding the SQL 2005 configuration. Further, he stated that he used a SQL Server SysAdmin account (in the SQL 2014 configuration) but it still failed.

  • What can I do if the old server is decomm'd?
  • If the server isn't decomm'd, and I can access, how do I extract all the logins, permissions, SID's, etc.?
  • Is it possible to create a new mapping from the SharePoint Central Admin site to a new SQL/Windows login?

Let me know if you need any other info and thank you in advance for your help!

1

This is an operating system error, reported to the SQL Server service. The SQL Server service account, which creates the files, needs to have at least change permissions on the d:\data folder and it needs to exist.

| improve this answer | |
  • I made the necessary changes to the SQL Server Agent account to have modify permissions to the folder in question and I'm still having the same error. I was sure this was the answer, there must be some sort of issue with SharePoint Central Admin? – Sean Perkins Jul 20 '16 at 13:17
  • you have to give the SQL Server Service account - not the agent account. The database engine itself creates the files. – Spörri Jul 20 '16 at 14:01
  • 1
    I gave the database engine modify permissions, still the same error. I just posted the answer to my question. – Sean Perkins Jul 20 '16 at 15:57
1

I believe I found the real issue.

SharePoint 2010 is NOT compatible with SQL 2014.

SQL Server 2014 and SharePoint supportability

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.