1

We have a clustered SQL server, and the backups of the databases are stored on the same drive where the data files are(F:). The storage team finally acted on my request to have a new clustered drive solely for SQL backups(G:). When I try to backup the database on the backup folder on the new clustered drive I get an error:

Cannot access the specified path or file on the server. Verify that you have the necessary security privileges and that the path or file exists. If you know that the service account can access a specific file, type in the full path for the file in the File Name control in the Locate dialog box.

I have already:

  • Assigned the cluster disk to SQL Server in WSFC
  • Added the SQL Server service account in the Security on the disk properties, and has been inhereted by the children
  • Changed the database settings on the instance properties to have the new path for backup

Is there anything else that i missed? I still cant backup to the new clustered disk. Does this process require a server restart?

  • 2
    Does the drive show up in sys.dm_io_cluster_shared_drives ? – Sean Gallardy Aug 10 '16 at 5:33
  • Hi, no its not showing up in there. How do i make it to show up in there? – rk13 Aug 10 '16 at 13:43
  • 3
    If it doesn't show up there, then you'll need to made the SQL Server cluster service DEPEND on the drive (add it to the sql server dependencies' in the cluster). Once you do that it will show up and allow you to use the drive. – Sean Gallardy Aug 10 '16 at 16:21
  • mssqltrek.com/2012/06/28/… thanks for leading me to this. This solved my issue. Thank you! – rk13 Aug 10 '16 at 19:45
  • @MaxVernon cleaned up and completed, sir. – Sean Gallardy Sep 22 '16 at 2:01
2

When adding clustered disk to an instance of SQL Server, there are a few steps that need to be taken.

  1. Present the disk to all possible owners of that disk (nodes)
  2. Bring the disk online from the first node that will own it
  3. Bring the disk into the cluster - it'll now reside in available storage
  4. Move the disk into the resource group for SQL Server
  5. Set the SQL Server resource to DEPEND on that new disk
  6. Double check sys.dm_io_cluster_shared_drives to see that SQL "sees" the disk. If it doesn't, one of the steps above was not successfully completed.

In this case, step 5 was missed which is why it didn't show up in the DMV listed in step 6.

0

How are you running your backups? Via SQL Agent Job? Are you able to run a backup manually via T-SQL (BACKUP DATABASE xyz TO DISK... etc. )?

I doubt that the fact the disk is clustered is causing this. Usually once you add clustered storage it's available immediately.

I would also check the Event Logs (Security) to see if there is any info there.

  • Yes, I am using SQL jobs to backup the server. From the looks of it, its working fine with T-SQL, and my backup jobs are running fine. You just cant use the GUI. I dont see the option of backing up to G:\ in the GUI. There are no logs pertaining to this issue as well. – rk13 Aug 10 '16 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.