I'm busy trying to migrate an informix database schema (with no data) to an informix database running on a different server.

I have exported the schema from the database using

dbschema -t all -d olddb schema.sql

Then I am trying to import it into my new database

dbimport /tmp/schema.sql -d newdb

I am getting the error

Cannot open sql script file

Looking through informix forums they are saying that this is because it cannot find the sql file but how can that be when I a specifying where it is?

Also if I go into the directory where the sql file is and try

dbimport schema.sql -d newdb

I get the same error

1 Answer 1


Never mind it seems dbimport won't work in this case because the schema wasn't generated with dbexport.

It worked when I did

dbaccess newdb /tmp/schema.sql

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.