1

I'm trying to install the Percona Audit_log plugin for my instance of MySQL.

I ran it previously so I know it works ok with MySQL (I'm sure it says so in the documentation anyway).

I have MySQL 5.5.47, so I downloaded the files for Percona server 5.5.47-37.7 and extracted the audit_log.so file.

I put that file into my plugin directory on the server (debian), but when I try to install it I get:

INSTALL PLUGIN audit_log SONAME 'audit_log.so';

Error Code: 1126. Cant open shared library '/usr/lib/mysql/plugin/audit_log.so' (errno: 13 /usr/lib/mysql/plugin/audit_log.so: undefined symbol: my_pthread_fastmutex_init)

I checked the permissions are the same as all the other files in that directory. Does anyone know if I need a different version for MySQL 5.5.47, I assumed the Percona versions matched the MySQL versions, or any ideas on it why it wont install?

  • did you download the Linux generic tarball from Percona repos? I just tried it myself, MySQL 5.5.47 Community Server using Percona Server 5.5.47 audit log plugin and it worked – jerichorivera Aug 26 '16 at 10:53
  • I did yes, it was Percona-Server-5.5.47-rel37.7-Linux.x86_64.ssl098.tar.gz I guess I have a different problem then. – IGGt Aug 26 '16 at 11:04
  • Try ssl100 or ssl101, I used *-ssl101.tar.gz – jerichorivera Aug 26 '16 at 11:41
  • cheers, I tried the 101 version , but it made no difference. – IGGt Aug 26 '16 at 12:28
  • 2
    can you run nm /usr/bin/mysqld | grep my_pthread_fastmutex_init, if there is no output then could be that your build was not compiled with the --with-fast-mutex option/WITH_FAST_MUTEXES feature – jerichorivera Aug 26 '16 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.