0

I have database in Vertica on 4 nodes (RedHat OS). It was working until I decided to restart my DB. After nodes were shut down, they can't be UP anymore.

I try to start DB via adminTools: nodes are starting to initialize, but then they shut down. Using last good epoch or admintools -t start_db with --force key don't help.

In logs (dbLog, vertica.log) I see only one type of error:

SP_connect: unable to connect via UNIX socket  to /tmp/4803 (pid=12533):
Error: Connection Refused.

It is enough space in /tmp and iptables service is disabled.

Also I tried to create new database, so it was created and worked well.

  • Can you please verify that the Socket file is cleared when the db is down, i.e that it is cleared properly. – cohenjo Aug 31 '16 at 14:48
  • @cohenjo, thank you! But what do you mean by "cleared properly"? – Vikora Sep 1 '16 at 15:20
  • Sometimes Vertica doesn't clear the socket file on crash- it prevents restarting the server. – cohenjo Sep 1 '16 at 15:34
0

kill all processes from Vertica :

ps -ef | grep vertica

This is avaialbe on all nodes.

Then start your database without the force option

admintools  -t  restart_node  --hosts= --database=--password= 

While starting the database make sure you tail the logs to capture the errors.

to get more solutions and Vertica fixes see this link

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.