0

I'm having an issue deploying the latest build of a database solution after creating some service broker objects. I am thinking that it could be related to not having service broker enabled on the database, as it gets created as part of the build, then deployed straight away.

Where can I set the "ENABLE BROKER" option so it get's executed before deploy, but after the database is created by SQLPackage ?

  • 1
    Do you have the EnableBroker database option set in your database project? I would expect SqlPackage to honor it during deployment. – Dan Guzman Sep 2 '16 at 10:36
  • @DanGuzman I couldn't find the option - I'll have a look again - thanks. – TaylorN Sep 2 '16 at 10:37
4

In the latest SSDT version, the EnableBroker option is under Database Settings-->Miscellaneous-->Service broker options. I would expect SqlPackage to honor this specification.

  • 1
    Database settings is present in project properties -> Project options – Nayana Setty Apr 21 '17 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.