0

I am moving my SQL server backups who run through the ola hallengren scripts to a new share.

On this share I granted full control to the AD-group containing the SQL Service accounts & the account which will execute the CMDEXEC through a proxy.

so far so good, this works for 4 out of 7 servers. For 3 other servers however this is not the case and I get the error that the directory does not exist.

For the 4 servers where I do not have any issues, I did not issue a service restart or anything else. I only created the credential and proxy and changed the path for the backup share. (the same as on all servers).

The servers are SQL Server 2012,2014 & 2016 and they all have the problem (or don't have)

Does anybody have any idea what might be going on? Something that I am missing?

  • Can you test a plain xp_cmdshell 'md' command to that share? - that would remove Ola's script from the problem and you could concentrate on pure Windows permissions – Scott Hodgin Sep 13 '16 at 12:18
  • Same error, directory does not exist – Stijn Wynants Sep 13 '16 at 12:33
  • Go down to basics to verify permissions to the share are good from the servers in question. Execute simple backups manually and also schedule using sql agent. See if Security logs or SQL logs show any type of permissions issue. An outside shot would be that even though you added all 7 service accounts to the share for permissions, make sure there isn't another group that is limiting permissions for the 3 that are failing. – Jason B. Sep 13 '16 at 13:30
  • Yes, tried that as well, the share is at top level, & at netapp we just got the storage admins & the service group. Strange issue, worked around it by adding folders for each server and adding in the service accounts tot the folder explicitly with full controll. Still strange it worked for 3 .... – Stijn Wynants Sep 13 '16 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.