1

I want to enable trace flags 4199, 8024, 9024, 1236 & 1117 on SQL SERVER (Startup Parameters).

I went to SQL Server Configuration Manager -> SQL Server ("instance_name"), and then clicked Properties -> Startup Parameters tab -> and I added -T4199 -T8024 -T9024 -T1236 -T1117 separately.

This is a SQL Server 2016 instance.

Restarted After this

used dbcc tracestatus(-1)

enter image description here

  • 1
    Add them one by one. Or use Powershell: erichumphrey.com/wp-content/uploads/2011/03/… – spaghettidba Sep 14 '16 at 10:42
  • I tried, but still the trace were not enabled...Also i want to ask if DBCC TRACEON(T4199 , -1) or adding -T4199 to startup parameter both are same ?? – joeprince Sep 14 '16 at 10:52
  • DBCC TRACEON(4199) enables the trace flag for a single session. DBCC TRACEON(4199, -1) enables the trace flag globally, in all sessions. Adding the startup parameter has a permanent effect, but requires a service restart. – Razvan Zoitanu Sep 14 '16 at 11:01
  • so is both same adding in startup or using dbcc traceon(4199,-1) – joeprince Sep 14 '16 at 11:14
  • dbcc traceon(4199,-1) would be in effect globally 'until server restart'. Adding trace flags to the startup parameters ensures they remain in effect after server restarts – Scott Hodgin Sep 14 '16 at 11:35
2

Try add each trace flag separately. multiple trace flags

Some trace flags are now build in, in SQL Server 2016 like TF 1117, TF 1236 only applies to SQL 2012 and 2014 without SP1, TF 4199 is now default as is TF 8024.

For the complete list of trace flags go to this url: https://msdn.microsoft.com/en-us/library/ms188396.aspx

| improve this answer | |
  • I added them seprately and restarted the service...but when i used DBCC TRACESTATUS() its showing value as 0 – joeprince Sep 14 '16 at 10:49
  • 2
    Execute DBCC TRACESTATUS(-1) – SQLStad Sep 14 '16 at 10:54
  • Still it shows status as 0 – joeprince Sep 14 '16 at 11:00
  • Could you please post a screenshot of the parameters like I did in the answer? – SQLStad Sep 14 '16 at 11:01
  • 1
    Just to be sure, you did restart the SQL Server service after you added the parameters, didn't you? – SQLStad Sep 14 '16 at 11:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.