2

When I query a table in my database, I am getting the error message as below.

Msg 596, Level 21, State 1, Line 0 Cannot continue the execution because the session is in the kill state. Msg 0, Level 20, State 0, Line 0 A severe error occurred on the current command. The results, if any, should be discarded.

During a scheduled task on the server, server got restarted because of an Windows Update and database status was set to 'Suspect'. We have repaired the database with data loss option using DBCC and the repair terminated with an error. All other tables in the database I can access.

SSMS Version

Microsoft SQL Server Management Studio                      12.0.5000.0
Microsoft Analysis Services Client Tools                        12.0.5000.0
Microsoft Data Access Components (MDAC)                     6.1.7601.17514
Microsoft MSXML                     3.0 4.0 6.0 
Microsoft Internet Explorer                     9.11.9600.18449
Microsoft .NET Framework                        4.0.30319.34209
Operating System                        6.1.7601

With SP2

Please help me to resolve the issue. I have transaction level backup. The data in those tables are static and I can load fresh data anytime. I am not worried about data in this table. I cannot even query this table. All the queries which refer this table has this issue. I have tried to drop this table but same error, tried to truncate same.

Below are the contents from dump file:

SqlDumpExceptionHandler: Process 80 generated fatal exceptionc0000005 EXCEPTION_ACCESS_VIOLATION. SQL Server is terminating this process.*                                                                                                                 
* BEGIN STACK DUMP:
*   09/18/16 05:55:06 spid 80*
Exception Address = 000007FEF57BC6A4 Module(sqlmin+00000000000FC6A4) 
*   Exception Code    = c0000005 EXCEPTION_ACCESS_VIOLATION *   Access Violation occurred reading address 0000000000000000
  • 1
    Also, since you repaired with allow data loss, which doesn't honor foreign key constraints, you may be hitting this: stackoverflow.com/q/34518205/3187747 – Erik Darling Sep 17 '16 at 15:11
  • Do you have transaction level backups? – David Sep 17 '16 at 15:40
  • 1
    If you have backups you should restore from backup. Looks like your DB is hosed. – Martin Smith Sep 17 '16 at 19:50
  • This looks like a bug in SQL server 2014. The fix is in SP2 CU3. Try it and let us know if that fixes the issue – Rashmi Feb 22 '17 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.