2

The server I am running has identity Management set to automatic for most of the tables I am replicating (A hand full have been set to manual). When the replication goes to change the range it changes the constraint BUT it does not change the identity seed of the table.

When users try and insert records, I get the not so clear message of

"If the identity column is automatically managed by replication, update the range as follows: for the Publisher, execute sp_adjustpublisheridentityrange; for the Subscriber, run the Distribution Agent or the Merge Agent."

These steps never seem to work and I end up have to reseed manually. Is there a setting I am missing? I have some suspicion that because some of the tables are set to manual and some set to automatic, the sp_adjustpublisheridentityrange does not work correctly when it is run by the merge process (If I run sp_adjustpublisheridentityrange manually with the @publication set, it errors out. If I run sp_adjustpublisheridentityrange with @table_name set, it works).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.