Your help is greatly appreciated. I spent a few hours trying to troubleshoot this and before I go to the firewall/network possibilities, i would like to check if my setup has any errors

I am unable to remote connect from my desktop using the VNN and port# to the named instance on non default port in the AOAG

Local connection tests - successful a) servername\instancename b)servername, port# c)server ip\instancename d)serverip, port# e)aoag listener\instancename f)aoaglistener, port# g)aoag listenerip\instancename h)aoaglistenerip, port#

Remote connection from desktop - successful if using server and instance names. But it fails if I try remote connection with VIP/VNN e)aoag listener\instancename f)aoaglistener, port# g)aoag listenerip\instancename h)aoaglistenerip, port#

I would like to use the separate AOAGlistener and port#s in the connection string.

I have validated -

  1. firewall rules work as tested from remote desktop using server ip and instancename/port#
  2. username password works
  3. using static ip and port#
  4. tcp is enabled and active/enabled are yes for each ip
  5. remote connectio is enabled.

Error information

Cannot connect to aoag_lsnr, 1551.

A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: TCP Provider, error: 0 - The specified network name is no longer available.) (.Net SqlClient Data Provider)

Server Name: aoag_lsnr, 1551 Error Number: 64 Severity: 20 State: 0

Thank you for your help.

  • Examine the answers found here. There are several answers that may lead you to your solution. stackoverflow.com/questions/3270199/… – RLF Oct 5 '16 at 1:22
  • This could be due to different reason. The most probable cause is UDP port is not open. Try to open UDP for the same number (as tcp). – Hailegziabher Dechassa Oct 5 '16 at 17:52
  • Do a network capture and see what is happening... Also Listeners don't use the browser service and have no idea what instance names are. Listeners, in fact, can't have instance names. – Sean Gallardy - Retired User Oct 5 '16 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.