1

I have literally installed on my development machine three different versions of SSMS standalone: 2008, 2012, 2014, and I work with SQL Server 2008 databases. On every single one of those versions, I tried to have IntelliSense display my available columns when I type a table alias and a dot "Table." for example. But that doesn't show up over 90% of the time. This happens similarly on any SSMS version I try.

I've searched for other people having this issue and found various cases, but none of those provided solutions, such as refreshing the IntelliSense cache and disabling/re-enabling IntelliSense itself, de-selecting e re-selecting certain options, work for me.

Could this be a problem related to the instances of SQL Server that I am connecting to, rather than with SSMS itself?

Edit: I have also tried to install a third party addon to SSMS, it then starts displaying as expected, but cripples my performance (making typing somewhat slower as it loads things in the background, which I really don't like), so I would rather fix the original functionality instead of resorting to that.

Thanks

3

SSMS 2016 is available for free. It has much better IntelliSense than in previous versions. https://msdn.microsoft.com/en-us/library/mt238290.aspx I highly recommend upgrading.

Other reasons why you may be having problems, from personal experience:

  1. Highly utilized server makes it take longer to work. I have personally seen it take 5 minutes on a really bogged down machine.
  2. Local machines with low resources.
  3. Incorrect query syntax. This can cause IntelliSense to not load anything because it can not tell what it is supposed to be doing.
  4. Poor connection between local machine and server. We just moved locations at my job, with a slower connection, and my IntelliSense load times have drastically changed.
  • 1
    Issue alleviated with the installation of SSMS 2016, it is in fact way more responsive. – Renato Oct 11 '16 at 20:01
0

Just tacking this on -- I ran a profiler on my VS2017 intellisense and found out that the query for synonym objects is pretty slow. So for anyone else using those, that might be the problem!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.