0

I have never changed this setting for an AlwasyOn setup. What is the best practise to do this? Should I change the setting on the Secondary node first and then the primary? Please suggest . The current setting is set to the default max value and that is something not which I want. Each of the server has 24gb of memory. The total size of the databases on each node is 105gb

Thanks

  • Don't think it matters which one you do first, the setting is dynamic and no restart of sql server is required. I would keep the MaxMem setting the same on both nodes so wherever the instance is living at the time can have the same memory setting. We have a similar setup where we have 24gb of memory on the nodes and we set the MaxMem to 18432MB which allows 6gb free to the OS on each node and we have not run into any memory issues. These nodes are sql dedicated also. – rvsc48 Oct 6 '16 at 14:52
  • Thank you. I was thinking something on similar line... To have 6 Gb for the OS and 18gb for each of the node. – user2923332 Oct 6 '16 at 14:53
0

The current setting is set to the default max value and that is something not which I want.

You should change your max memory setting away from the default. Its a dynamic setting that does not require a restart of sql server service. Bear in mind that running reconfigure it will flush out the plan cache.

Refer to my answer here for more details.

Each of the server has 24gb of memory. The total size of the databases on each node is 105gb

Start with 21GB as max memory provided you are running only SQL Server (no SSIS, SSRS, SSAS,etc). Leave 3 GB for OS.

Depending on the database activity, the RAM (24GB) seems to be low. You should look out for low memory notifications to see if server is having memory pressure.

Not the answer you're looking for? Browse other questions tagged or ask your own question.