I've been trying to install SQL Server 2008 R2 with tools.

I've downloaded thisn version and it just won't work!

I've had some problems installing Visual Studio SP1 due to silverlight4 being already installed, so I figured i needed to uninstall everything that had something to do with sql server, so I did.

Still the errors show up.

These 2 errors show up at the beginning of the installation during "Setup support files".

(I can't post more than 2 url's yet, so Ive put all the screenshots in 1 image, sorry)


enter image description here

The first error is the top left one, and retry fails, and when I hit cancel a few secs later the second error pops up and the installation terminates.

My OS is W7 x64 with all updates installed.

I don't really know how to go on actually. I've searched for hours yesterday without any results.

Anybody got a clue? Before I reinstall every .net-related programs.

So far I've tried:

  • I checked if the first file shown in error 1 is actually there, and it is.

  • Tried to run the setup explicitly as administrator

  • I checked if the second file/folder was present, and it was not. So I manually created the folder and file, which then causes the first error to say the same, but then it says can't create
    \SqlSupport_Cpu64_1_ComponentUpdate_1.log, then I tried
    to create an empty file with that name and extention. This makes the installer append the filename with "_1". If I create that file too, it just
    appends with a higher count.

  • Uninstalled every sql server related program (e.g sql server compact)

  • Reset all the permissions on the e: disk and formatted it.

Thanks in advance!

  • It looks like it's a permissions issue. Try running the setup as a local admin. Do you have admin privileges on this box? – Thomas Stringer Mar 17 '12 at 17:22
  • @ChristopheDeTroyer you should make your commend an answer. – mrdenny Mar 18 '12 at 7:27

I found the cause of the problem. Recently I'd set my default program files folder to my hdd, because my C: is a 60 GB SSD. The key is located in the register at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion. The keys "ProgramFilesDir" and "ProgramFilesDir (x86)" are the ones that need to be default ("C:\Program Files" and "C:\Program Files (x86)") in order for it to work. Sorry for the unnecessary post.

| improve this answer | |
  • 1
    +1 nice point to know for troubleshooting. We do not know how the clients have their systems setup. – StanleyJohns Mar 19 '12 at 4:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.