2

How can I set the Auto growth values in SQL Server 2016? The usual place in the database Properties -> Files is not available.

enter image description here

migrated from stackoverflow.com Oct 20 '16 at 13:05

This question came from our site for professional and enthusiast programmers.

  • 1
    Be very careful when considering autogrowth setting, if you size your database too small and you have too many autogrowth events it will kill your performance. – Vladimir Oselsky Oct 20 '16 at 13:12
  • It is a Development box, so that should be fine. I am trying to change it on a production backup, and it was deactivated there with larger initial size – Moslem Ben Dhaou Oct 22 '16 at 13:27
7

enter image description here

I see the option on my UI? but I had to scroll, failing that have you tried running the TSQL

USE [master]
GO
ALTER DATABASE [YOURDB] MODIFY FILE ( NAME = N'TheFile', FILEGROWTH = 10240KB )
GO
  • 1
    The TSQL helps,... Nothing in the UI... – Moslem Ben Dhaou Oct 22 '16 at 13:28
1

The key for me was in the missed 'but I had to scroll' part. I didn't notice that there was a scrollbar at the bottom of the list at first, but when I went back and looked it was there and I was able to set it using the GUI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.