0

I am trying to load my table with some data using bcp. Below is the bcp command that I am using

bcp Job.DBO.FileWatch in ABC.txt -C -t\t -S server\rept -T -f bcp1.fmt

The schema of the FileWatch table is like this. It is just a dummy table

enter image description here

And the ABC.txt file from where I am reading the data is like this

enter image description here

And the format file looks like this.

enter image description here

But when I run my bcp command, it is not throwing any error and at the same time no rows are copied. I read every link on Google's first and second page and tried every switch they mentioned but still it was not working. Any idea why this could be happening?

1

What is -C (upper case)? That's for the code page.

You should have -C { ACP | OEM | RAW | *code_page* } according to MSDN.

I think you mean -c (lower case), which is for the character data type.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.