0

I have problems adding a databases to Always ON. When I try to connect to named instance I get an error:

enter image description here

Names are correct. Also when I try to connect from server a to server b with server\instance is giving same error, but just server is working? But here server name is greyed out so I cannot change it? On server itself when I use server\instance is working.

I did not set DNS Aliases, maybe I need to do that?

Any ideas?

Thanks

  • Sounds like SQLBrowser isn't started.. You have two options: 1) start the sql browser service. 2) click the options button and add "SERVER=MyServer,Port" without the quotes. – Sean says Remove Sara Chipps Oct 21 '16 at 13:12
  • Hi, SQLBrowser is started and it is now working. But option 2 WORKS, Thanks! Do I maybe need to set DNS Alias for it? – mehnihma Oct 21 '16 at 13:57
  • DNS Alias won't help you as it's having problem resolving the port. If browser is running make sure port 1434 UDP isn't being blocked by a firewall. – Sean says Remove Sara Chipps Oct 21 '16 at 14:57
3

When named instances are having issues being connected to, there is generally an issue with one of the following:

  1. SQL Browser isn't running
  2. SQL Browser ports are blocked (1434 UDP)
  3. Incorrect DNS entries
  4. SQL TCP Port is blocked (custom port number for named instance)
  5. SQL TCP Port is blocked (Dynamic ports)
  6. TCP is not an enabled protocol

To workaround it, either start the SQL Browser service or unblock the port(s).

Additionally, with the SQL Server Management Studio connection dialog it is possible to press the "options" button in the lower right hand corner and override any of the preset options. In this instance, using SERVER=MyServer,Port to specify the server name and port number overrides the SQL Browser port lookup and allows for a direct connection without name to port resolution.

  • Additionally possiblility that the TCP protocol is not enabled for the instance (although indications are that this is not the case for OP) – Nic Oct 21 '16 at 17:53
  • True @Nic , that is a possibility, let me add it for completeness. – Sean says Remove Sara Chipps Oct 21 '16 at 20:07
  • I have tried everything you suggested and still have same error, i have also tried with spn, but nothing. same error. Only server=server works – mehnihma Oct 24 '16 at 12:54
  • @mehnihma If you're not using SSMS 2016, try updating to that and see if it works. You have a workaround as of now, though. – Sean says Remove Sara Chipps Oct 24 '16 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.