I have a database called FDB. I have created this database on my PC with SQL Server Express Edition and added one table. I made a backup of this database. The SQL Server version on the server is 2005.

I copied this backup to the server and tried to restore it, but I get this message:

The media family on device C:\Program File\Microsoft SQL Server\MSSQL.1\MSSQL\Bacup\FDB.bak is incorrectly formatted. SQL Server cannot process this media family. RESTORE Headeronly is terminating abnormally. Microsoft SQL Server error 3241

  • Are you restoring to the same server, or a different server? If it's a different server, make sure that it's the same version.
    – DForck42
    Mar 21, 2012 at 15:43

3 Answers 3


If you have created the backup of a SQL Server 2008 database and are trying to restore it on a SQL Server 2005 instance, you will receive this error. You cannot do this.

Your best bet would be to script out the database (as long as all of the schema and objects are 2005 compatibile). You can't downgrade a database.

  • I see. the database on my pc is
    – Pinchas K
    Mar 21, 2012 at 14:11
  • @PinchasK Ok. I think your only option here would be to script out your database (schema and data) and execute that against your 2005 instance. I don't know of any other way. Mar 21, 2012 at 19:20

You need to fix the connection so it is using the SQL 2008 instance.

Try to run the SQL Server 2008 Express install program again, and during Name Instance configuration, specify a Name Instance with a different name. Example: MachineName\instancename

After installation, logged in with New Instance name created.

Try to create database, create tables for database and try to run restore again. It will work

Source: http://dotnetguts.blogspot.in/2010/06/restore-failed-for-server-restore.html


If you're restoring a SQL Server 2008 database on a SQL Server 2005, using backups won't work. You can script a database instead:

In SSMS Object Explorer right click a database Select Tasks, Generate Scripts

enter image description here

Check 'Script all objects in the selected database'

enter image description here

In the Choose Script options: Set ' Script for Server version' to SQL Server 2005 Set'Script data' to true to insert the data. It's false by default

enter image description here

When the script is created, create a database with the same name on SQL Server 2005 and execute the script

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.