0

I'm trying to install OJVM on Oracle 11g (11.2.0.2.0) on Amazon Linux AMI (20016.09). And I'm getting the following error after running initjvm.sql:

PL/SQL procedure successfully completed.

create or replace java system
begin if initjvmaux.startstep('CREATE_JAVA_SYSTEM') then
*
ERROR at line 1:
ORA-29538: Java not installed
ORA-06512: at "SYS.INITJVMAUX", line 23
ORA-06512: at line 5

Running

SQL> select comp_name, version, status from dba_registry;

shows this:

COMP_NAME
--------------------------------------------------------------------------------
VERSION                        STATUS
------------------------------ --------------------------------------------
Oracle Application Express
4.0.2.00.09                    VALID

Oracle XML Database
11.2.0.2.0                     VALID

Oracle Text
11.2.0.2.0                     VALID


COMP_NAME
--------------------------------------------------------------------------------
VERSION                        STATUS
------------------------------ --------------------------------------------
Oracle Database Catalog Views
11.2.0.2.0                     VALID

Oracle Database Packages and Types
11.2.0.2.0                     VALID

JServer JAVA Virtual Machine
                               LOADING


COMP_NAME
--------------------------------------------------------------------------------
VERSION                        STATUS
------------------------------ --------------------------------------------
Oracle XDK
11.2.0.2.0                     VALID

The install is started and up until that point shows no errors, and everything seems to run and complete successfully, and the dba_registry shows an in progress install. Anyone have any ideas on what the issue could be?

1

A basic overview of feature availability for different database editions:

Products and Services - Database - Enterprise Edition - Comparisons

Java is not available in Express Edition.

  • Thanks for the response, but the OJVM can be loaded. I've done done with XE - Oracle 11g on Windows 7. I'm wonderijng why the same load would not be possible for XE on Linux. – Bixxman Oct 31 '16 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.