I am trying to migrate to a new PostgreSQL database on Amazon Redshift and get the following error:

Connection to jdbc:postgresql://redshift-cluster-i-created:5439/dev wasn't established. ERROR: code 0

To connect I am using the AWS Schema Conversion Tool->Connect to Amazon RDS for PostgreSQL.

Server name: Cluster-name-as-created-on-redshift
Server port: 5439 as is the default AWS port
Database: left blank to connect to the default database I created
User name and password as created on AWS.

For the Server name I also tried the JDBC URL as per the cluster info on AWS but without the 'jdbc:redshift://' prefix or ':5439/dev' postfix.

Then I tried the public IP address of the AWS cluster for the Server name, then I tried the AWS cluster Endpoint as the Server name.

None worked. Any ideas?

1 Answer 1


I managed to connect using the full endpoint as given by AWS (less the port number), and then following the instructions to add your IP address to your EC2 vpc security group here:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.