0

I do not understand why memory bar seems to exceed to the red zone with 24.5 MB while RDS server should be with 1Gibenter image description here

  • That looks like 24.5 MB free memory (so, approximately 999.5 MB of 1024 MB is not free). Check the monitoring graphs? Click Instance Monitoring, Single Metric, and check that? – Michael - sqlbot Nov 10 '16 at 13:09
0

If you have the performance_schema enabled, then this will consume roughly 500Mb of RAM, then in addition to that you need to take into account your buffer pool size settings (RDS defaults these to 3/4 of the RAM).

Adding these two together can push the allocated ram size over 1Gb quite quickly - note that you have 182Mb of swap used too.

The 24.5Mb of free RAM is probably the OS file cache, which can be discarded by the OS should other RAM demands become too much.

Try turning off the performance_schema in the RDS parameter group and see if that makes any difference.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.