I'm using code I checked out from SVN. Whenever I run make in ./extensions/, I get

for DIR in postgis  postgis_tiger_geocoder  postgis_topology address_standardizer; do \
    echo "---- Making all in ${DIR}"; \
    make -C "${DIR}" all || exit 1; \
---- Making all in postgis
make[1]: Entering directory '/home/ecarroll/code/postgis/extensions/postgis'
mkdir -p sql_bits/
/usr/bin/perl -pe 's/BEGIN\;//g ; s/COMMIT\;//g' ../../postgis/postgis_for_extension.sql > sql_bits/postgis.sql
make -C ../../doc comments
make[2]: Entering directory '/home/ecarroll/code/postgis/doc'
make[2]: Nothing to be done for 'comments'.
make[2]: Leaving directory '/home/ecarroll/code/postgis/doc'
cp ../../doc/postgis_comments.sql sql_bits/postgis_comments.sql
cp: cannot stat '../../doc/postgis_comments.sql': No such file or directory
Makefile:72: recipe for target 'sql_bits/postgis_comments.sql' failed
make[1]: *** [sql_bits/postgis_comments.sql] Error 1
make[1]: Leaving directory '/home/ecarroll/code/postgis/extensions/postgis'
Makefile:26: recipe for target 'all' failed

Whenever I run make comments in the root I get a small portion of those errors,

make comments
make -C doc comments
make[1]: Entering directory '/home/ecarroll/code/postgis/doc'
make[1]: Nothing to be done for 'comments'.
make[1]: Leaving directory '/home/ecarroll/code/postgis/doc'

How do I resolve this?

1 Answer 1


You need xsltproc,

16:02 < robe2> EvanCarroll: Looks like you are probably missing xsltproc

Install xsltproc (instructions in Ubuntu/Debian)

sudo apt-get install xsltproc;


make distclean;

And try again. It should work.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.