2

I've been performing kind of intensive schema dropping and creating over a PostgreSQL server,

ERROR: out of shared memory

HINT: You might need to increase max_locks_per_transaction.

I need to increase max_locks_per_transaction but how can i increase it in MAC OSX

closed as off-topic by mustaccio, RDFozz, Md Haidar Ali Khan, hot2use, Colin 't Hart Sep 18 '18 at 11:26

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Too localized - this could be because your code has a typo, basic error, or is not relevant to most of our audience. Consider revising your question so that it appeals to a broader audience. As it stands, the question is unlikely to help other users (regarding typo questions, see this meta question for background)." – mustaccio, RDFozz, Md Haidar Ali Khan, hot2use, Colin 't Hart
If this question can be reworded to fit the rules in the help center, please edit the question.

0

Check the postgres.conf file. The parameter is defined there. On windows I found it in the data directory so I guess it will be the same for Mac OSX.

Not the answer you're looking for? Browse other questions tagged or ask your own question.