0

Like the title suggests, I want to bulk export data within an sql server 7.0 database into a file and then import it to an sql server 2008 r2 database, I did the following, I first typed this command on the windows 2000 shell:

C:> bcp sticom.dbo.societe format nul -c -f C:\test.fmt -t, -T

it was executed successfully, then I copied the C:\test.fmt in a network shared folder so I can access it from the other windows 7 system, I then copied on the desktop and tried to execute this command on the command prompt:

C:\ bcp sticom.dbo.societe in C:\test.bcp -f C:\test.fmt  -T

and I got this error:

SQLState = 08001, NativeError = 2 Error = [Microsoft][SQL Server Native Client 10.0][SQL Native Client]An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. SQLState = S1T00, NativeError = 0 Error = [Microsoft][SQL Native Client]Login timeout expired

I checked my connection, I checked the services and the paths, everything was in place

0

The BCP utility attempts to connect to the default instance if you don't specify the -S parameter. My guess is there is no default instance available for the 'import' BCP.

  • I don't understand – Mohamedali Hamdi Nov 21 '16 at 15:13
  • Is your 'import' command running on a server/computer that does NOT have a default Sql Server instance? The error you're getting leads me to believe that BCP can't connect to a default instance since you did not specify the -S parameter to force BCP to connect to a named instance. – Scott Hodgin Nov 21 '16 at 15:15
  • I am not sure but I think it doesn't have a default instance, it's sql server 7 – Mohamedali Hamdi Nov 21 '16 at 15:37
  • As I understand your question, the export FROM 7.0 works fine. Your 7.0 instance would have to be the default instance for the BCP command to work without specifying the -S parameter, I'm talking about the second BCP - that's the one that's failing, correct? That is Sql 2008 R2 correct? Does it have a default instance or a named instance? – Scott Hodgin Nov 21 '16 at 15:42
  • I am working with the default instance I think – Mohamedali Hamdi Nov 21 '16 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.