0

I try to create a database file in this location enter image description here

I've checked the route and everything, I've tried several times to create the tablespace like this...

enter image description here

...but as you can see, I was just lead to several errors. What can I do? What am I doing wrong?

2
  • Do you have permission on that directory? Under which user are you running SQL*PLUS? Administrator?
    – atokpas
    Nov 29 '16 at 11:31
  • @JSapkota the user you are logged into Oracle as does not matter. It's the Oracle service that needs permission on the directory in order to create the datafile
    – Philᵀᴹ
    Nov 29 '16 at 14:38
-1

Do you have permission on this directory? Under which user are you running SQL*PLUS? Administrator? – if no than got permission first

if yes

CREATE TABLESPACE lmtbsb DATAFILE 'file_path/lmtbsb01.dbf' SIZE 50M
    EXTENT MANAGEMENT LOCAL AUTOALLOCATE;
5
  • I'm logged as SYSTEM... When I try to use that order, it leads me to the same error. Thank you very much for your quick answer though!
    – Lena
    Nov 29 '16 at 11:45
  • you are not added '01' or any other 'file_path/lmtbsb01.dbf' in your file_name add it than create Nov 29 '16 at 11:49
  • Do you mean create a something01.dfb file as in your example apart from the one I want to create, or that I should add the "01" next to the name of my file? I'm sorry, I know I am an absolute newbie.
    – Lena
    Nov 29 '16 at 12:21
  • yes add 01 or any other in file name Nov 29 '16 at 12:23
  • Same error... I don't know what it can be.
    – Lena
    Nov 29 '16 at 12:31
-1

I had the same error and I fixed it by giving permissions to the Oracle user that I was using, as shown below

fix error

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.